An ode to eBuyer Support

UPDATE 28/11/2013: eBuyer have finally contacted me, over two months after originally opening the ticket. They offered me an apology, and a direct line and email address of someone higher up in the support department. I may consider buying from them again, although I still do not have the power adapters. (There’s no point in them being sent now as I bought alternatives.)

Just over a week ago I ordered 2 cisco Wifi adapters for work, using eBuyer business. They both support power-over-ethernet (which unfortunately I don’t have) or can be used with the supplied DC power adapters. At least, that’s what the description said. Instead, they arrived just with kettle leads, but no adapters.

No problem I thought, this is the kind of thing that technical support are normally very happy to put right. Their support options are “eNotes” which apparently will be answered “within 48 hours”, or a premium rate 10p-per-minute number. Yes, for a business service.

Being the skinflint that I am, I refused to use the premium phone, and instead used the eNote system. My queries were promptly answered by “samantha”, who may or may not be human, and always suggested that her “supervisor” or “product manager” would get back to me straight away.

I even resorted to poetry (not something I am known for my capacity for) as a way to get their attention. Alas, my lyrical efforts were met with stony-faced (some may say “robotic”?) deferment.

I thought that one week was probably enough time to resolve a “didn’t-ship-the-right-power-adapter” issue, and decided just to order something that would work from another site, but given the effort I put into my poetry, and the lack of acknowledgement it got, I have decided to post the entire thread here for posterity. An ode to “samantha” at eBuyer business support.

Full thing after the jump:

Simon Detheridge 
05/09/2013 23:57 
The Cicso wireless access points I received appear to have been shipped
with the incorrect power adapters.

The "adapters" are labelled OEM-AIR-PWR-CORD-UK. On the packing
list, they are listed as "Cisco cable F/ Aeronet OEM", SKU
R001175.

However, the actual "adapters" are just kettle leads. The
access points expect a 48vDC power adapter.

Please could you send the correct power adapters ASAP?

Samantha
06/09/2013 12:26 
Dear Simon Detheridge,

Thank you for contacting our Customer Support Team.

I can confirm that I will need to look into this with the product manager.
As soon as I have a response I will be in contact.

Please accept my apologies for any inconvenience or annoyance caused as a
result of this matter.

Kind Regards,

Samantha

Ebuyer.com
Customer Support Team

Simon Detheridge 
06/09/2013 17:10 
Thank you. It would be great if you could expedite this. I ordered the
items next-day, but they’re pretty much useless until I can plug them in.
Samantha
06/09/2013 17:28 
Dear Simon Detheridge,

Thank you for your response.

I can confirm as soon as I have a response I will be in touch.

Please accept my apologies for any inconvenience or annoyance caused as a
result of this matter.

Kind Regards,

Samantha

Ebuyer.com
Customer Support Team

Simon Detheridge 
10/09/2013 16:25 
Your supervisor is not being very helpful and I still have two items that I
cannot use. Please elevate this issue.
Samantha
10/09/2013 16:34 
Dear Simon Detheridge,

Thank you for your response.

I apologise for the delay in responding to your enote.
I am still awaiting a response from the product manager. I have chased this
now and will be in contact shortly.

Please accept my apologies for any inconvenience or annoyance caused as a
result of this matter.

Kind Regards,

Samantha

Ebuyer.com
Customer Support Team

Simon Detheridge 
11/09/2013 10:50 
In case this clears things up, I’ve uploaded a photo of the device, and
the AIR-PWR-CORD-UK that was sent with it.

It’s here:
http://imgur.com/XyfC2wr
(I couldn’t see a way of attaching an image to an eNote)

The photo shows ALL available ports on the wifi unit. There are none on the
other side. It also shows the AIR-PWR-CORD-UK, which is clearly a kettle
lead.

Note: None of the ports shown on the wifi unit will accept a kettle lead. I
suppose I could shove the kettle lead hard into the ethernet port and then
RMA it? That might be quicker than this process.

I wrote a little poem to lighten the mood, and try and get things moving
along:

Oh, Samantha’s supervisor
I wish you would reply
It’s been nearly 5 days now
And I’m starting to cry
Our wifi needs, they are not met
Because of these devices
We simply cannot plug them in
It could be called a crisis
Our employees roam the halls
Their ipads disconnected
And all because these access points,
They cannot be connected

Please help!

Samantha
11/09/2013 10:53 
Dear Simon Detheridge,

Thank you for your response.

I should hopefully have a response today for you.

Please accept my apologies for any inconvenience or annoyance caused as a
result of this matter.

Kind Regards,

Samantha

Ebuyer.com
Customer Support Team

Simon Detheridge 
12/09/2013 12:36 
Dear Samantha, your prediction
Of some contact yesterday
Was sadly quite inaccurate
I was hoping you to say
That my issue was resolved
And you’d send some power supplies
But instead I’m met with silence
As my optimism dies
Samantha, I’m not even sure
Judging from your replies
That you are actually human
But a robot in disguise
An automatic reply that says
"Supervisor’s investigating"
When actually there’s no-one there
And my notes are simply waiting
But just in case you are a person
I’ll dry my eyes with a tissue
And plead with you just one more time:
"Please escalate this issue!"
Samantha
12/09/2013 12:39 
Dear Simon Detheridge,

Thank you for your response.

I am sorry about this. i will chase it up again today.

Please accept my apologies for any inconvenience or annoyance caused as a
result of this matter.

Kind Regards,

Samantha

Ebuyer.com
Customer Support Team

Simon Detheridge 
14/09/2013 22:05 
Samantha, I am sad to say
This missive may well be
My last upon this subject, ’cause
It’s clearly plain to see
Ebuyer tech support is not
Such a capable unit
When after such a long time you
Can’t ship the missing bit
I know that POE will work
To plug my units in
But there’s a DC port as well
And time is running thin
Alas, my switch does not support
Ethernet plus power
And so the units remain unused
Hour after hour
The advertised power units show
No sign of their arrival
And having decent wifi here
It helps my job’s survival
So I’ve ordered power injectors
That will make the units go
That’s from another site of course
YOUR tech support’s too slow
Unfortunately this event
Forced me to the conclusion
I’ll use another site from now
Which has the key inclusion
Of a functional support service
Which does not take a week
To get an answer from a person
On advice I seek
I’m sad to say I’ll also leave
Some negative reviews
On other sites that provide ratings
And other kinds of news
In fact I’m so upset by this such
Time consuming slog
I may take this entire eNote
And post it on my blog

If “Samantha” is indeed human I’m sorry to have shamed her personally here. I’m sure it’s not her fault, but the system in which she works. She’s not sent me a terse reply at half-ten on a Saturday evening, so perhaps she is human after all. Maybe they just switch her on at certain times, or maybe working in such a depressing environment has made her immune to poor attempts at humour.